Error in manual build of L4Android

Matthias Lange mlange at sec.t-labs.tu-berlin.de
Mon Jun 10 14:03:10 CEST 2013


On 09.06.2013, at 19:39, Itamar O wrote:

> I believe I'm using the most recent versions,

Can you try r42 please?

Matthias.

> as I set up the system today by running:
> $ svn cat http://svn.tudos.org/repos/oc/tudos/trunk/repomgr | perl - init http://svn.tudos.org/repos/oc/tudos fiasco l4re l4linux_requirements
> and
> $ git clone git://git.l4android.org/kernel.git l4android
> (as instructed in the manual build page- http://l4android.org/build/manual_build.html)
> 
> - Itamar.
> 
> 
> On Sun, Jun 9, 2013 at 8:29 PM, Matthias Lange <mlange at sec.t-labs.tu-berlin.de> wrote:
> On 09.06.2013, at 17:30, Itamar O wrote:
> 
>> Hello,
>> I am trying to perform a manual build of L4Android (x86) on a Ubuntu 10.04-x64 host.
>> I have successfully built fiasco.oc and l4re (was able to run the hello world image on qemu),
>> but the l4android make fails with the following error:
>> arch/l4/built-in.o: In function `l4re_ma_alloc':
>> /home/itamar/AndroidWorkspace/l4android/obj/tudos/include/l4/re/c/mem_alloc.h:156: undefined reference to `l4re_ma_alloc_a
>> /home/itamar/AndroidWorkspace/l4android/obj/tudos/include/l4/re/c/mem_alloc.h:156: undefined reference to `l4re_ma_alloc_a
>> /home/itamar/AndroidWorkspace/l4android/obj/tudos/include/l4/re/c/mem_alloc.h:156: undefined reference to `l4re_ma_alloc_a
>> /home/itamar/AndroidWorkspace/l4android/obj/tudos/include/l4/re/c/mem_alloc.h:156: undefined reference to `l4re_ma_alloc_a
>> make[1]: *** [vmlinux] Error 1
>> make: *** [sub-make] Error 2
> 
> This looks like a mismatch between the L4Re and the L4Android kernel version. Which version are you using?
> 
> Matthias.
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.l4android.org/pipermail/l4android-dev/attachments/20130610/61070fed/attachment.html>


More information about the l4android-dev mailing list