Error in manual build of L4Android

Itamar O itamarost at gmail.com
Tue Jun 11 20:25:11 CEST 2013


On Mon, Jun 10, 2013 at 9:28 PM, Matthias Lange <
mlange at sec.t-labs.tu-berlin.de> wrote:

> On Mon, Jun 10, 2013 at 08:51:39PM +0300, Itamar O wrote:
> > On Mon, Jun 10, 2013 at 3:03 PM, Matthias Lange <
> > mlange at sec.t-labs.tu-berlin.de> wrote:
> >
> > > On 09.06.2013, at 19:39, Itamar O wrote:
> > >
> > > I believe I'm using the most recent versions,
> > >
> > >
> > > Can you try r42 please?
> > >
> >
> > Sure, gladly.
> > Risking a foolish question - how do I change the checked out revision
> when
> > using the repomgr script? (or where can I found instructions that don't
> use
> > repomgr?)
>
> repomgr is just a convinience tool which wraps around svn. So you can use
> standard svn commands to checkout older versions. Make sure to "update"
> both
> the fiasco and the l4 repository.
>

Found out that repomgr does support explicit revisions:
$ export REPOMGR_SVN_REV=42
$ svn cat http://svn.tudos.org/repos/oc/tudos/trunk/repomgr | perl - init
http://svn.tudos.org/repos/oc/tudos fiasco l4re l4linux_requirements

with this, the l4android build completed successfully!
still haven't got to creating an image and running it, but at least the
initial issue is resolved.
Thanks Matthias!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.l4android.org/pipermail/l4android-dev/attachments/20130611/3c831a43/attachment.html>


More information about the l4android-dev mailing list