L4Android boot process not completed successfully ("cannot find /system/...")

Matthias Lange mlange at sec.t-labs.tu-berlin.de
Mon Jul 8 08:33:04 CEST 2013


On 28.06.2013, at 14:29, Itamar O <itamarost at gmail.com> wrote:

> Ok, great that you got it working.
> 
> Did you build Android for x86? Because then there is a bug in our config so
> that the build system is missing to copy init.l4android.rc to the root fs.
> 
> Matthias.
> 
> Yes, I did build for x86.
> 
> Next I would like to make some modifications.
> Could you please supply pointers to how to achieve any or all of my next goals?
> 1. Dual boot Android and Linux.

You can use the same Linux kernel as for Android. Just supply it with an alternative ramdisk.

> 2. Modify the microkernel to send certain events from the Android VM to the Linux VM (e.g. specific sycalls).

There is no need to modify the microkernel. You can use l4shmnet to create a network connection between the two Linux kernels.

> 3. Build the entire system for ARM instead of x86.

You need to use the Google 2.3.7_r1 branch. Then use the configs we provide at git.l4android.org.

Best,
Matthias.


-- 
Dipl.-Inf. Matthias Lange <mlange at sec.t-labs.tu-berlin.de>
Security in Telecommunications
TU Berlin / Deutsche Telekom Laboratories
Ernst-Reuter-Platz 7, 10587 Berlin
Phone: +49 - 30 - 8353 58 553
Mobile: +49 - 160 - 587 28 07
Web: http://www.t-labs.tu-berlin.de/sect
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.l4android.org/pipermail/l4android-dev/attachments/20130708/adb8caab/attachment.html>


More information about the l4android-dev mailing list